On Windows Client, got lock lost message, about a lock on a specific file is broken and whether you want to grab lock again. What does the message mean?
How the lock works:
- When distributed lock is on (it is on by default), open a file in Windows client will lock the file automatically. It will prevent other users from modifying the file. Once you close the file, it will be uploaded to the cloud and release the lock.
- While you are working on the file, Windows client will keep the lock heartbeat with the server, to maintain the lock. If the server doesn't heard from client for 15 minutes, it will assume the client is gone and unlock the file, to prevent the file from locking permanently
- The error message means while you still have the file open, you lost the lock now. And it gives you the option to lock the file again.
Possible cause:
- Tenant admin can release the lock from web portal directly.
- When you have a file open and the machine goes to sleep, the windows client doesn't send heartbeat message anymore.
- You have a network issue, which prevents windows client from communicating with the server for the heartbeat message.
Solution:
- If you are still working on the file, just click 'yes' to grab the lock again.
- If your machine doesn't go to sleep, please check your network connection.
- As cluster admin, you can define how long the server releases the lock when it doesn't get the heartbeat message. The setting is under Cluster Control Panel, Settings, Timeouts and Limits, Distributed Lock Idle Timeout
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